1
0
Fork 0
ccnet-aur/PKGBUILD

81 lines
2.6 KiB
Bash

# Maintainer: Aaron Lindsay <aaron@aclindsay.com>
# Name of the Software your PKGBUILD will install - should be unique. See PKGBUILD#pkgname
pkgname=ccnet
# The version number for the software
pkgver=1.4.1
_seafilever=2.1.2
#The release number for the arch package, as fixes are added to the PKGBUILD, the release number will increase
pkgrel=3
# The description of the package, should be about 80 characters long (one line)
pkgdesc="A framework for writing networked applications in C."
# The type of processor this software can build and work on. See PKGBUILD#arch
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
# The official website for the software your PKGBUILD will install
url="https://github.com/haiwen/ccnet/"
# The License that the software is released under. See PKGBUILD#license
license=('custom')
# Packages that your software needs to run. If the dependancy requires a minimum version number use the >= operator
depends=('libevent>=2.0' 'libzdb>=2.10.2' 'libsearpc>=1.2.1' 'jansson>=2.2.1' 'libldap' 'python2>=2.6')
# Packages that must be installed to build the software, but at not necessary to run it
makedepends=('vala>=0.8' 'pacman>=4.1')
# Optional packages that extend the software's functionality
optdepends=()
# List of Package names that this PKGBUILD provides. Put modified packages that will be installed here.
provides=()
# Change the default behavior of makepkg see PKGBUILD#options
options=
source=("https://github.com/haiwen/ccnet/archive/v${_seafilever}.tar.gz"
"https://raw.github.com/haiwen/ccnet/master/COPYRIGHT"
"libccnet.pc.patch"
"0001-Add-autoconfiguration-for-libjansson.patch")
sha256sums=('1333ee62e0987fa9e695e88c1a4339f82c55f1af86e6343773f440bb7f8dec5d'
'7abb45e3e313d37337b088411fa249171f58186ebf951c19ea2bf1390927a0f3'
'66c3b02c3981db6a80819e0ae103bedadf8dfdf81405a7f75a9cba714acf973f'
'72f8f8fd79c0b570335240e4ef53357bb70f25477b66beddaa445ee27d350674')
configure_ccnet() {
./autogen.sh
CFLAGS="-lpthread" ./configure --enable-server --enable-ldap --prefix=/usr PYTHON=/usr/bin/python2
}
pkgver() {
cd "$srcdir/$pkgname-$_seafilever"
configure_ccnet &> /dev/null
grep "PACKAGE_VERSION" Makefile | sed 's/PACKAGE_VERSION.*=[ \t]\+\([0-9\.]\+\)[ \t]*/\1/g'
}
prepare () {
cd "$srcdir/$pkgname-$_seafilever"
patch -p1 -i $srcdir/libccnet.pc.patch
patch -p1 -i $srcdir/0001-Add-autoconfiguration-for-libjansson.patch
}
build () {
cd "$srcdir/$pkgname-$_seafilever"
configure_ccnet
make -j1
}
package () {
#install library and header files
cd "$srcdir/$pkgname-$_seafilever"
make DESTDIR="$pkgdir/" install
#copy license over
mkdir -p $pkgdir/usr/share/licenses/$pkgname
cp $srcdir/COPYRIGHT $pkgdir/usr/share/licenses/$pkgname/
}